
nanoHUB tutorial

West Coast Theoretical Chemistry meeting
David Strubbe
5 May 2024

Acknowledgments
Cottrell Scholar Award and NSF CAREER award DMR-2144317



nanoHUB and the MIT Atomic-Scale Modeling Toolkit
NSF-funded project since early 2000s, headquartered at Purdue University
GUIs for simulations, course resources, webinars, forums. Computation is done remotely on their clusters.
https://nanohub.org/tools/ucb_compnano/
Begun for graduate Computational Nanoscience class at UC Berkeley in 2007, developed originally by Elif 
Ertekin (now at UIUC) and Jeffrey Grossman (now at MIT).
I was TA and developer for class in 2009. I am main developer at UC Merced since 2016, with Enrique Guerrero.
Design philosophy: manage complexity of underlying code, less is more
No need for: SSH, Bash, Fortran, make, SLURM, emacs, gnuplot, Python, etc.

Component tools

http://www.quantum-espresso.org
P. Giannozzi et al., J. Phys. Condens. 

Matter 21, 395502 (2009)

https://nanohub.org/tools/ucb_compnano/


Weekly exercises in discussion for Condensed 
Matter Physics (undergrad/grad)
GAMESS; atomic energy levels and wavefunctions
GAMESS; covalent, ionic, and van der Waals bonding
Molecular dynamics; radial distribution function, solids, liquids
Quantum ESPRESSO; vibrations in 1D chains
XCrySDen; visualization of 2D crystal structures
XCrySDen; visualization of Brillouin zones
Quantum ESPRESSO; vibrations in graphene and diamond
XCrySDen; visualization of paths through Brillouin zones
Quantum ESPRESSO; bandstructures of 2D materials
Monte Carlo (Ising model): paramagnetism, ferromagnetism, 

and antiferromagnetism
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CURE on Raman spectra of MoS2xSe2(1-x) monolayer alloys
• Final project, with presentations and papers.
• Lecture on 2D materials’ unique physics and applications.
• Each of 17 students assigned one of 22 symmetry-unique structures in a 2×2 supercell with 8 S 

atoms
• HW: calculate relaxed structure and Raman spectrum of pristine MoS2 and MoSe2
• HW: calculate relaxed structure of assigned structure
• Presentation: relaxed structure, choice of property (e.g. density of states, elastic tensor, piezoelectric 

tensor, etc.)
• Submit data to spreadsheet and output repository: structure, bandgap, phonon data, etc.
• Final paper: analyze full class data set, find most stable structure, identify trends.
• Quantum ESPRESSO tool, density-functional (perturbation) theory. Parallel for large calculations.



Students’ data set on MoS2xSe2(1-x) monolayer alloys
Lattice 

constants

Bond lengths

Raman 
spectra

(Note anomaly)
Formation 
energies



CURE in sophomore-level modern physics class (PHYS 10)

MoS2 / MoTe2

Using SIESTA code in our nanoHUB toolkit: 
A. García et al., J. Chem. Phys. 152, 204108 (2020). 

https://departments.icmab.es/leem/siesta/

study space: 
monolayer 

heterojunctions 
of MX2 (M=Mo, 

W; X=O, S, Se, Te)

quantum well 
lasers

relation to particle in a 
box

https://departments.icmab.es/leem/siesta/
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More examples and exercises, and info on CUREs, in several 
webinars linked from tool’s Supporting Docs 
(https://nanohub.org/resources/ucb_compnano/supportingdocs)

https://nanohub.org/resources/ucb_compnano/supportingdocs


8Getting set up in nanoHUB

• Create free account on nanoHUB.org (you can “log in through 
your institution” and choose UC Merced or other institutions)

• Go to https://nanohub.org/tools/ucb_compnano/ or select “MIT 
Atomic-Scale Modeling Toolkit” in the list of tools, and click the 
heart to set it as a “favorite” for future use

https://nanohub.org/tools/ucb_compnano/


9nanoHUB general tips

• All computation is done remotely, none on your device.
• You cannot directly copy or paste in the nanoHUB window because it is a view of a remote process.
• nanoHUB saves the results of each run so you can go back and compare, with the blue slider on the 

Simulate pane. You can even plot the results from several runs together on the same axes.
• You can have multiple sessions open (and running) at once, in different tabs or browsers. These 

sessions remain active even if you close the browser, turn off your laptop, etc. for a few days, and can 
be accessed via the “Dashboard” when you login to nanoHUB.

• You can resize the tool window to make it bigger, so you can see more of it without scrolling, via the 
bottom right button with arrows.

• Sometimes the tool window gets minimized into a small rectangle. You can make it come back typically 
by clicking the bottom right button with a circle and arrow, or by resizing.

• If you see no data in the Results panes, or you don’t have a Simulate button, try “Clear All” and rerun the 
simulation.

• You can reset the zoom of a plot by clicking on the square button in the upper right corner.
• If you hover the mouse over an option in the graphical user interface (GUI), generally some text will 

appear to give you more information.
• You can download output files or plots by clicking on the button with a green arrow. 
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Within the MIT Atomic-Scale Modeling Toolkit we can use stand-alone XCrySDen.
Select subtool “Crystalline Structures and Densities (XCrySDen)”.

A. Kokalj, J. Mol. Graphics Modelling 17, 176-179 (1999); http://www.xcrysden.org/

Try one of the xsf files (not a bxsf) in the example section, and consider:
• What kind of structure is this?
• How many nearest neighbors does each atom have?
• Measure bond lengths and angles among nearest neighbors. 
• How many atoms are in the unit cell?
• What are the lengths of each lattice vector?
• What is the angle between the lattice vectors?

• See next slide for tips on XCrySDen.

visualizing crystal structures

http://www.xcrysden.org/
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• The view you get when you load a structure is the unit cell. The box drawn is the edge of the unit cell. An atom counts as inside the cell if 
its center is: we have to worry about sharing between cells only if the atom is exactly on the edge, face, or corner.
Only atoms inside the unit cell are drawn, but atoms exactly on the boundaries or corners will be shown in multiple copies. The cell is in 
2D, with only 2 lattice vectors.

• Atoms are colored according to a default color for each element. You can change these if necessary if the atoms in your structure happen 
to have the same default color.
Modify->Atomic Colors

• XCrySDen draws bonds based on a simple distance criteria, using default atomic radii for each atom. Whether a line is drawn does not 
always correspond to the physical concept of bonds given the arbitrary cutoff. You can adjust these to make bonds show up if they don’t, 
for ease of visualization.
Modify->Atomic Radius.
Increase the chemical connectivity factor a little and click “Update.” Adjust so that the bonds you want appear and ones you don’t do not 
appear.

• You can expand beyond the unit cell to have multiple copies, helpful for judging what the crystal structure looks like on a bigger scale.
Modify->Number of Units Drawn. The boxes shown are still the unit cell.

• Rotating the system to view from different angles: click, hold down, and drag to rotate.
You can align to different Cartesian directions with the buttons on the right that have red arrows.

• To measure bond lengths: At the bottom of the pane, Distance button. Then click on the two atoms.
• To measure bond angles: At the bottom of the pane, Angle button. Then click on the three atoms.
• Note: You can determine properties of the lattice vectors by measuring lengths and angles between atoms that are periodic replicas of 

each other, i.e. constitute a lattice.
• The coordinate system can be turned on by pressing the keyboard shortcut “y”.
• The crystal cell can be turned on by pressing the keyboard shortcut “c”.

XCrySDen tips



Bonding in diatomic molecules: 
energy and orbitals



13GAMESS

• Go to https://nanoHUB.org and log in.
• Go to the MIT Atomic-Scale Modeling Toolkit at 

https://nanohub.org/tools/ucb_compnano
• Click the blue button “Launch Tool”
• In the “Application” menu in the upper right, select “Quantum 

Chemistry (GAMESS)”

https://nanohub.org/
https://nanohub.org/tools/ucb_compnano


14define a diatomic molecule

• For “Coordinate File” select “New”.
• In the Coordinate Data section at the bottom, clear the text and 

enter:
2

H 0 0 -1
H 0 0  1

This means 2 H atoms, at coordinates (0, 0, -1 Å) and (0, 0, 1 Å).

This structure is a guess about an appropriate structure.
What is the bond length in our guess?



15find the equilibrium structure

• For “Basis Set” select “6-311G* (High)”
• For “Method” select “DFT-B3LYP”
• For “Run Type” select “Optimize Structure”

• After run, check “Atomic Coordinates” panel, and look at 
coordinates of last step. What is the equilibrium bond length?

• Note the total energy (from “Key Outputs”, the last one listed which 
is for the last step, and choose the one in eV).



16eigenvalues and molecular orbitals at 
equilibrium bond length

• For “Run Type” select “Energy Only”
• In Coordinate Data, change the coordinates to (0, 0, L/2) and (0, 0, 

L/2), where L is the equilibrium bond length you found.

• Note the total energy (from “Key Outputs”, in eV) and confirm it is the 
same as from your “optimize” run.

• Note the HOMO (high-occupied molecular orbital) and LUMO (lowest 
unoccupied molecular orbital) energies (from “Eigenvalues”). 3 decimal 
places will be sufficient. You can either copy these by hand, or if you 
prefer, copy and paste from the “Key Outputs” by clicking on the icon 
to the right of “Result:” with a green arrow.

• In Jmol, look at the molecular orbitals of the HOMO and LUMO. You 
can determine which numbers these are from the occupations in the 
“Eigenvalue Log.” You may need to set zoom to 50%. Take screenshots 
and describe what they look like and how they differ from each other.



17plot bonding curves

• We are going to make two plots:
(1) total energy vs. bond length;
(2) HOMO and LUMO energies vs. bond length.

• For “Run Type” select “Energy Only”
• Turn off “Run Jmol?” for simplicity.

• Choose 4 more bond lengths (L=0.6d, 0.8d, 1.2d, 1.4d), where 
d=equilibrium length found in previous step. You can divide these up 
among a group and share your results.

• For each, in Coordinate Data, enter (0, 0, -L/2) and (0, 0, L/2).
• Note the total energy, HOMO, and LUMO after each calculation.
• Make these two plots (1: total energy; 2: HOMO and LUMO).
• Think about how they relate to what we know about bonding 

potential energy V(r), and which kind of bond is in H2. How do the 
HOMO and LUMO plots help understand why the H atoms are 
bonded together?



18more molecules

• Repeat this exercise for He2 and LiF (2 Å should be ok as guess).
• Note that Li is purple and F is green in Jmol.
• Compare the equilibrium bond lengths for each.
• Note any differences you find among H2, He2, and LiF in the 

molecular orbitals and the bonding curves for total energy, HOMO 
and LUMO.

• Connect these differences to the kind of bonding in these molecules.

If you have more time:
• Calculate each atom involved here individually, and use these total 

energies to determine the bonding energy ΔE for each molecule.
• Try N2.



19nanoHUB: example H2 results



Calculation of specific heat by 
classical molecular dynamics



21MD of (6,6) carbon nanotube
• Go to https://nanohub.org/tools/ucb_compnano/ or select “MIT Atomic-

Scale Modeling Toolkit” in the list of tools
• Choose “Molecular Dynamics (Carbon Nanostructures and More)”
• Choose Simulation Type -> Minimize Coordinates
• XYZ Coordinates -> (6,6) CNT
• Simulate.

• Look at Jmol animation. How would you describe this structure of carbon 
atoms? How is it changing during the minimization?

• Go back to the “Molecular Dynamics…” tab.
• Check the Potential Energy plot in “Results” dropdown menu. Note down 

the final value (hover mouse over point to get more significant figures), 
which is for T = 0.

https://nanohub.org/tools/ucb_compnano/


22MD of (6,6) carbon nanotube
• Click “Input”.
• Choose Simulation Type -> Dynamics
• Thermostat -> Yes (NVT)
• Temperature (Kelvin) -> 100
• Number of simulation steps -> 10000
• Restart from previous run -> Yes
• Simulate.

• Look at Jmol animation, and Total Energy plot: The total energy will 
change at first (as the thermostat operates), then come to thermal 
equilibrium.

• Check the temperature plot to see how the thermostat works, verifying that 
the temperature is what you expect.

• If you don’t see at least 1000 steps in equilibrium, restart and run for more 
steps.

• Note the energy (with an approximate error bar) of this equilibrium value.
• If the error bar is more than ~1 eV, restart and run longer to get better 

statistics.



23MD of (6,6) carbon nanotube
• Repeat this workflow, restarting each time, for 200 K, 300 K, 400, 500 K.
• Plot the Total Energy (with error bars) vs Temperature, and estimate Cv, 

the specific heat. What can you compare this too?



Lennard-Jones molecular dynamics, 
radial distribution function



25noble gases
• Go to the MIT Atomic-Scale Modeling Toolkit at 

https://nanohub.org/tools/ucb_compnano
• Select “Molecular Dynamics (Lennard-Jones)”
• This subtool will simulate the motion of particles interacting via 

the Lennard-Jones potential, appropriate for a noble gas such as 
Ar.

• Note that it works in periodic boundary conditions: you can see 
atoms move outside the box on one side and return on the other.

• Start by running with defaults, and look at Jmol animation of 
motion, and the Radial Distribution Function. What is the starting 
state and the final state, in terms of the “types of matter”?

https://nanohub.org/tools/ucb_compnano


26noble gases
Then do a more refined calculation with:
• Set Number of particles = 256
• Set Temperature = 0.0 [note: the resulting temperature will be 

nonzero; this is just about how the velocities are initialized]
• Box Size = 7
• Timestep = 0.01
• Number of simulation steps = 10000

• Analyze the radial distribution function, in terms of typical 
distances, coordination shells, etc.

• Repeat with Number of simulation steps = 10.
• What do you see in the radial distribution function now? Why?


